スポンサーリンク

gem install bundlerを実行したらBundler could not find compatible versions for gem “bundler”メッセージが出たので対処したときのメモ

スポンサーリンク
スポンサーリンク

gem install bundlerを実行したらBundler could not find compatible versions for gem “bundler”メッセージが出たので対処したときのメモ。

環境
Windows10
Ruby 2.4.10

メッセージを読むと「which depends on bundler (< 2.0, >= 1.3.0)」と出力されていた。

メッセージの通りbundlerのバージョンは2.0未満、1.3.0以上でないとならないようだ。

gem listを実行して現在のbundlerのバージョンを確認してみる。

bundler (2.2.3)と確認ができた。

> gem list
bundler (2.2.3)

とりあえず、2.0未満をインストールするためにgem install bundler -v “< 2.0″を実行する。

再びgem listを実行して確認をすると、bundler (2.2.3, 1.17.3)となっており、1.17.3がインストールされたことが確認できた。

> gem install bundler -v "< 2.0"
> gem list
bundler (2.2.3, 1.17.3)

そこで、bundle installを実行すると再度Bundler could not find compatible versions for gem “bundler”メッセージが表示された。

> bundle install
Fetching gem metadata from https://rubygems.org/..........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies.................
Bundler could not find compatible versions for gem "bundler":

どうやら、bundlerのバージョンを指定しないといけないのですね。

3度目の正直でバージョンを指定して実行する。bundle _1.17.3_ install。

> bundle _1.17.3_ install

これで元々エラーになっていた箇所は通過できました(そのあと別のエラーが出たのはまた別の話)。

Rubyistからすると当たり前かもしれませんが、知らなかったのでメモとして残しておきます。

以上、gem install bundlerを実行したらBundler could not find compatible versions for gem “bundler”メッセージが出たので対処したときのメモでした。

コメント

タイトルとURLをコピーしました